Skip to main content

Reply to this post | Go Back
View Post [edit]

Poster: JeffT Date: Aug 26, 2009 3:07pm
Forum: movies Subject: Redrive of thumbnails and animated gif failing

I updated the following item (by replacing the video file with a new one):
http://www.archive.org/details/scipy09_advancedTutorial_8

When I rederived the item, new thumbnails and a new animated gif are not being generated.

Log of re-derive task is here:
http://www.us.archive.org/log_show.php?task_id=46100770

I think the jobs to generate the thumbnails and animated gif are timing out as happened with the other item I posted about. Both sections in the log have an error "137". Part of log for the thumbnail job is below:


Thumbnail maker: length=1.8 hour => Thumb every 60 seconds (rate:0.0166666666667)

[ PDT: 2009-08-26 09:05:30 ] Executing: /petabox/sw/bin/timeout -s 9 3600 /usr/bin/ffmpeg -v 0 -i /tmp/derive/scipy09_advancedTutorial_8/scipy09_advancedTutorial_8.mp4 -an -s 160x90 -padtop 10 -padbottom 10 -padcolor 000000 -r 1 /tmp/derive-scipy09_advancedTutorial_8-Thumbnails/%08d.jpg > /dev/null 2>&1


warning: /petabox/sw/bin/timeout -s 9 3600 /usr/bin/ffmpeg -v 0 -i /tmp/derive/scipy09_advancedTutorial_8/scipy09_advancedTutorial_8.mp4 -an -s 160x90 -padtop 10 -padbottom 10 -padcolor 000000 -r 1 /tmp/derive-scipy09_advancedTutorial_8-Thumbnails/%08d.jpg > /dev/null 2>&1 exited with error retval:137, but told to continue on...


Cleaning up temporary dir:
[ PDT: 2009-08-26 10:05:31 ] Executing: rm -rf /tmp/derive-scipy09_advancedTutorial_8-Thumbnails/

--------------- Module Thumbnails Finished PDT: 2009-08-26 10:05:32 (Took 1.0 hour) ------------------->

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Sep 22, 2009 1:33pm
Forum: movies Subject: Re: Redrive of thumbnails and animated gif failing

looks like a "straight up timeout"
where it ran out of time (1 hr)

it *should* be given just shy of 3 hrs to run (at least current code does -- but i thought i put that in 1-2 ago??)
anyway, rederiving and will watch it (and suspect it should work fine...)

--t

Reply to this post
Reply [edit]

Poster: parvatisri Date: Aug 4, 2010 8:25am
Forum: movies Subject: Re: Redrive of thumbnails and animated gif failing

I see that the ffmpeg was creating jpeg files, not the gifs for the thumbnails. Or maybe I misread the command line?

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Aug 21, 2010 10:27am
Forum: movies Subject: Re: Redrive of thumbnails and animated gif failing

yes, it makes jpeg(s) for the thumbnail(s) (single still images)
and an animated GIF for the overall item image (w/ typically 2+ still frames animated)

-tracey